Opened 14 years ago

Closed 11 years ago

#100 closed defect (fixed)

test_shallow water_domain failing

Reported by: Duncan <duncan.gray@…> Owned by: Duncan and Ole
Priority: low Milestone:
Component: Testing and validation Version: 1.0
Severity: normal Keywords:
Cc:

Description

I get this error when installing ANUGA, not precompiled

on win2000, python 2.3.

#The problem is the gauge_values[X] are 52 long, not 51.

I've added a hack to the code so the test doesn't fail, since the test is not there to test the length of the gauge_values, but it would be good to know what is causing the problem and removing the hack.

ERROR: test_another_runup_example
----------------------------------------------------------------------

Traceback (most recent call last):
  File "test_shallow_water_domain.py", line 1043, in test_another_runu
p_example
    assert allclose(gauge_values[1], G1)
  File "C:\Software\Python23\lib\site-packages\Numeric\Numeric.py", li
ne 707, in allclose
    d = less(absolute(x-y), atol + rtol * absolute(y))
ValueError: frames are not aligned

----------------------------------------------------------------------

Change History (2)

comment:1 Changed 14 years ago by Duncan <duncan.gray@…>

the hack is revision 3806

comment:2 Changed 11 years ago by nariman

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.