Opened 17 years ago

Closed 14 years ago

#119 closed defect (wontfix)

unhashable type error on runcairns

Reported by: steve Owned by: ole
Priority: normal Milestone:
Component: Testing and validation Version: 1.0
Severity: normal Keywords:


I tried to run from the demos. I get the following error:

Traceback (most recent call last):

File "", line 93, in ?

domain = Domain(meshname, use_cache = True, verbose = True)

File "/home/steve/ga/anuga_core/source/anuga/shallow_water/", line 146, in init


File "/home/steve/ga/anuga_core/source/anuga/abstract_2d_finite_volumes/", line 86, in init


File "/home/steve/ga/anuga_core/source/anuga/abstract_2d_finite_volumes/", line 146, in pmesh_to_domain

verbose = verbose)

File "/home/steve/ga/anuga_core/source/anuga/caching/", line 349, in cache

T = apply(func,args,kwargs)

File "/home/steve/ga/anuga_core/source/anuga/abstract_2d_finite_volumes/", line 179, in _pmesh_to_domain

tag_dict = pmesh_dict_to_tag_dict(mesh_dict)

File "/home/steve/ga/anuga_core/source/anuga/abstract_2d_finite_volumes/", line 204, in pmesh_dict_to_tag_dict

sides = calc_sides(triangles)

File "/home/steve/ga/anuga_core/source/anuga/abstract_2d_finite_volumes/", line 228, in calc_sides

sides[a,b] = (id, 2) #(id, face)

TypeError?: unhashable type

Change History (2)

comment:1 Changed 17 years ago by steve

Just tried runcairns on my PC running python 2.3. It works! On bogong with python 2.4 we get the error!

comment:2 Changed 14 years ago by nariman

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.