Opened 17 years ago

Closed 12 years ago

#137 closed defect (fixed)

test_caching crashes

Reported by: duncan Owned by: ole
Priority: lowest Milestone:
Component: Testing and validation Version: 1.0
Severity: normal Keywords:
Cc:

Description

I got this error when running anuga_core\source\anuga\test_all.py in Windows. (Note, not the standard test_all.py)

Traceback (most recent call last):
  File "test_all.py", line 100, in ?
    suite = regressionTest()
  File "test_all.py", line 88, in regressionTest
    modules = map(__import__, moduleNames)
  File "caching\test_caching.py", line 419, in ?
    clear_and_create_cache(Dummy_memorytest, verbose=False)
  File "caching\test_caching.py", line 36, in clear_and_create_cache
    verbose=verbose)
  File "I:\inundation\anuga_core\source\anuga\caching\caching.py", line 360, in
cache
    funcname, dependencies, compression)
  File "I:\inundation\anuga_core\source\anuga\caching\caching.py", line 1074, in
 save_results_to_cache
    mysave(T,datafile,compression)  # Save data to cache
  File "I:\inundation\anuga_core\source\anuga\caching\caching.py", line 1266, in
 mysave
    Ts  = pickler.dumps(T, bin)
cPickle.PicklingError: Can't pickle test_caching.Dummy_memorytest: import of mod
ule test_caching failed

Change History (2)

comment:1 Changed 17 years ago by ole

  • Owner changed from Ole to ole
  • Priority changed from normal to lowest
  • Status changed from new to assigned

This test has been commented out because, although the test will pass inside the caching dir and also at the anuga_core level, it won't pass at the anuga_core/source/anuga level.

If we need to verify this functionality, just uncomment and run again.

Two test were disabled due to this issue. See changeset:4385 for details.

comment:2 Changed 12 years ago by habili

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.