Opened 13 years ago

Closed 11 years ago

#205 closed defect (fixed)

test_all failing on windows for current release - due to test_advection.py

Reported by: duncan Owned by: Stephen
Priority: lowest Milestone:
Component: Functionality and features Version:
Severity: normal Keywords:
Cc:

Description

I installed ANUGA from anuga-1.0beta_4733.tgz onto a windows box and got the following error;

__________________________________________________________

.....................................................WARNING: Too small timestep

 0.0000000000000000 reached even after 50 steps of 1 order scheme

E...............................................................................

................................................................................

................................................................................

................................................................................

................................................................................

................................................................................

........................................

======================================================================

ERROR: test_advection_example (test_advection.Test_Advection)

----------------------------------------------------------------------

Traceback (most recent call last):

  File "advection\test_advection.py", line 166, in test_advection_example

    for t in domain.evolve(yieldstep = 0.05, finaltime = 10):

  File "C:\Python24\lib\site-packages\anuga\advection\advection.py", line 362, i

n evolve

    skip_initial_step=skip_initial_step):

  File "abstract_2d_finite_volumes\domain.py", line 1117, in evolve

    self.evolve_one_euler_step(yieldstep,finaltime)

  File "abstract_2d_finite_volumes\domain.py", line 1176, in evolve_one_euler_st

ep

    self.update_timestep(yieldstep, finaltime)

  File "abstract_2d_finite_volumes\domain.py", line 1483, in update_timestep

    raise Exception, msg

Exception: WARNING: Too small timestep 0.0000000000000000 reached even after 50

steps of 1 order scheme

 

----------------------------------------------------------------------

Ran 653 tests in 107.307s

 

FAILED (errors=1)

Change History (7)

comment:1 Changed 13 years ago by duncan

Just run the latest version of ANUGA and got the same error.

I get it when I'm running on C:, but not when I run in Perlite. I'm also getting this log error;

Testing path ...C:\inundation\anuga_core\source\anuga:

Files tested;
test_domain.py, test_ermapper.py, test_general_mesh.py, test_generic_boundary_co
nditions.py, test_ghost.py, test_neighbour_mesh.py, test_pmesh2domain.py, test_q
uantity.py, test_region.py, test_util.py, test_advection.py, test_alpha_shape.py
, test_caching.py, test_geo_reference.py, test_lat_long_UTM_conversion.py, test_
point.py, test_redfearn.py, test_inundation_damage.py, test_fit.py, test_interpo
late.py, test_search_functions.py, test_geospatial_data.py, test_loadASCII.py, t
est_generate_mesh.py, test_generate_meshII.py, test_mesh.py, test_mesh_interface
.py, test_data_manager.py, test_most2nc.py, test_shallow_water_domain.py, test_s
mf.py, test_system.py, test_cg_solve.py, test_numerical_tools.py, test_polygon.p
y, test_quad.py, test_sparse.py, test_system_tools.py,

................................................................................
......................................................WARNING: Too small timeste
p 0.0000000000000000 reached even after 50 steps of 1 order scheme
E...............................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................
======================================================================
ERROR: test_advection_example (test_advection.Test_Advection)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "advection\test_advection.py", line 166, in test_advection_example
    for t in domain.evolve(yieldstep = 0.05, finaltime = 10):
  File "C:\inundation\anuga_core\source\anuga\advection\advection.py", line 362,
 in evolve
    skip_initial_step=skip_initial_step):
  File "abstract_2d_finite_volumes\domain.py", line 1077, in evolve
    self.evolve_one_euler_step(yieldstep,finaltime)
  File "abstract_2d_finite_volumes\domain.py", line 1140, in evolve_one_euler_st
ep
    self.update_timestep(yieldstep, finaltime)
  File "abstract_2d_finite_volumes\domain.py", line 1447, in update_timestep
    raise Exception, msg
Exception: WARNING: Too small timestep 0.0000000000000000 reached even after 50
steps of 1 order scheme

----------------------------------------------------------------------
Ran 662 tests in 96.231s

FAILED (errors=1)

Error in atexit._run_exitfuncs:
Traceback (most recent call last):
  File "C:\Python24\lib\atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "C:\Python24\lib\logging\__init__.py", line 1333, in shutdown
    h.close()
  File "C:\Python24\lib\logging\__init__.py", line 674, in close
    del _handlers[self]
KeyError: <logging.StreamHandler instance at 0x00F400A8>
Error in sys.exitfunc:
Traceback (most recent call last):
  File "C:\Python24\lib\atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "C:\Python24\lib\logging\__init__.py", line 1333, in shutdown
    h.close()
  File "C:\Python24\lib\logging\__init__.py", line 674, in close
    del _handlers[self]
KeyError: <logging.StreamHandler instance at 0x00F400A8>

C:\inundation\anuga_core>

comment:2 Changed 13 years ago by ole

  • Component changed from Appearance and visualisation to Testing and validation

I will try this with a more recent distribution.

comment:3 Changed 13 years ago by ole

  • Owner changed from ole to duncan

The test that fails belongs to the advection module - which is hardly ever being used let alone kept up to date.

On Linux platforms it is excluded from the test because of weave.

However, it is interesting that the error can be reproduced on Windows by going to the advection folder and running test_advection.py - likewise it can be reproduced by checking out the repository on the C-drive and running test_all as Duncan noticed.

HOWEVER - on the network drive, when running test_all.py, test_advection is not run at all. That is a mystery!

I have included some print statements in the advection module and the test to see if it gets called on other platforms.

Duncan, can you please run test all and see if it gets called as it should?

Thanks

comment:4 Changed 13 years ago by duncan

  • Owner changed from duncan to ole

got test_advection running from test_all

comment:5 Changed 13 years ago by ole

  • Component changed from Testing and validation to Functionality and features
  • Owner changed from ole to stephen
  • Priority changed from normal to lowest

Disabled the offending test, commented the logging info out (as this causes errors in the test suite as well) and finally decided to exclude test_advection.py on all platforms for the time being. See changeset:4796

It is there to revive whenever someone needs to. I have flicked this ticket to Stephen as he can decide whether to revive it.

comment:6 Changed 13 years ago by ole

  • Owner changed from stephen to Stephen
  • Summary changed from test_all failing on windows for current release. to test_all failing on windows for current release - due to test_advection.py

comment:7 Changed 11 years ago by nariman

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.