Opened 13 years ago

Last modified 11 years ago

#223 reopened defect

sww2domain is failing in (DISABLED)test_sww2domain2

Reported by: ole Owned by: ole
Priority: low Milestone:
Component: Testing and validation Version:
Severity: minor Keywords:
Cc:

Description

Currently the parameter minimum_storable_height controls the smallest depth ANUGA is willing to store. However, Rudy van Drie noticed that momenta are stored for depths smaller than that resulting in sww files that have regions with nonzero momentum but zero depth. This is counter intuitive and causes problems if one wants to compute flow speed maps from sww files.

Change this in data_manager.py so that momentum is set to zero in sww files whenever depth is less than minimum_storable_height.

I assign this to Jane as Duncan will be busy with ticket:222

Change History (7)

comment:1 Changed 13 years ago by ole

  • Owner changed from jane to ole

I'll take this.

comment:2 Changed 13 years ago by ole

  • Component changed from Functionality and features to Testing and validation
  • Owner changed from ole to duncan

Done in changeset:4868 On test, however, still fails. It is test_sww2domain2 in data_manager.py which deals with NaN values in SWW. I'll pass that on onto to Duncan. Please close this ticket when the test works again.

comment:3 Changed 13 years ago by duncan

  • Owner changed from duncan to someone
  • Priority changed from normal to low
  • Summary changed from minimum_storable_height should also control storage of momentum to sww2domain is failing in (DISABLED)test_sww2domain2

I think Peter did this function. I am not aware of it being used these days...

comment:4 Changed 12 years ago by ole

  • Cc duncan removed
  • Owner changed from someone to rwilson

comment:5 Changed 11 years ago by ole

  • Owner changed from rwilson to ole

comment:6 Changed 11 years ago by ole

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 11 years ago by ole

  • Resolution fixed deleted
  • Status changed from closed to reopened

The problem is not with depth which has been fixed for some time. However, reenabling the test revealed problems with NaN's and 'filler'.

Disabled test again, but really, this should be looked at.

Note: See TracTickets for help on using tickets.