Opened 16 years ago

Last modified 12 years ago

#275 new enhancement

Refactor set_values in

Reported by: ole Owned by: habili
Priority: normal Milestone:
Component: Architecture and API Version:
Severity: normal Keywords:


This code needs a revamp. The semantics of 'location' and 'indices' isn't clear and we also need to have the option of restricting the area by specifying a polygon as requested by rajaraman 22 April 2008.

I suggest we get rid of edge_values as an option and also to rename 'unique vertices' to the more intuitive name 'nodes' and let that be the default. This is what is set using point sets by least squares anyway. I the user needs to set vertex_values by triangle e.g. to include discontinuities it may be better to imply that by the shape of input value in case it is an array.

I also suggest that we allow restrictions by region_tag in set_quantity to roll set_region in seemlessly. In fact set_region could probably be refactored using set_quantity with the polygon in question allowing for more code reuse.

This ticket should be done in conjunction with ticket:250 and ticket:254

Change History (2)

comment:1 Changed 16 years ago by ole

Perhaps also add option where data outside polygon is updated rather than inside. This would allow users to cut out areas from an elevation dataset and replace them with something else (e.g. buildings)

comment:2 Changed 12 years ago by habili

  • Owner changed from ole to habili
Note: See TracTickets for help on using tickets.