Opened 17 years ago

Closed 17 years ago

#43 closed defect (fixed)

Duplicate points in interior regions cause spurious mesh

Reported by: sexton Owned by: duncan
Priority: normal Milestone: Mesh generation maintenance
Component: Functionality and features Version: 1.0
Severity: normal Keywords: duplicate polygon points
Cc: duncan

Description

Created interior region polygon which had duplicate points. Called create_mesh_from_regions, with resulting mesh could not even be seen, as viewed through swollen. In addition, saw diagnostic output of "Vertex 23 does not belong to a triangle". No exceptions were thrown.

Change History (5)

comment:1 Changed 17 years ago by ole

  • Status changed from new to assigned

comment:2 Changed 17 years ago by sexton

This issue is broader than duplicate points (and may not even be duplicate points!). See document at

Z:\inundation\sandpits\jsexton\ANUGA\production\sydney_2006\The Black Screen of Death.doc

which looks at some tests to try and track down what might be causing the black screen. Note, ANUGA is happy to continue integrating, but swollen cannot display the output (maybe at least one value is extreme).

comment:3 Changed 17 years ago by sexton

I think this is broader than duplicate points (and probably isn't even that!). See document at

Z:\inundation\sandpits\jsexton\ANUGA\production\sydney_2006\The Black Screen of Death.doc

where a series of tests are described to try and track down the problem. The output can not be viewed in swollen, and this is probably due to either one or a number of extreme values being allocated to the mesh. ANUGA is happy to integrate throughout.

comment:4 Changed 17 years ago by ole

  • Milestone changed from AnuGA ready for release to Mesh generation maintenance
  • Owner changed from ole to duncan
  • Severity changed from minor to normal
  • Status changed from assigned to new

We now believe that this is the cause of 'black screen of death'. Removing duplicate vertices resolves it. To automatically protect against this condition we need pmesh to either throw out duplicates or throw out orphaned vertices.

comment:5 Changed 17 years ago by duncan

  • Resolution set to fixed
  • Status changed from new to closed

see ticket #23

Note: See TracTickets for help on using tickets.