Opened 17 years ago

Closed 17 years ago

#46 closed defect (fixed)

test_all at ANUGA level fails for me

Reported by: duncan Owned by: duncan
Priority: normal Milestone:
Component: Testing and validation Version: 1.0
Severity: normal Keywords:
Cc:

Description

test_all at the root level fails. This is in Windows. It doesn't do this for Ole ;

Testing path ...I:\inundation:
  test_interpolate.py
  test_quad.py
  test_mesh.py
  test_quantity.py
  test_cg_solve.py
  test_sparse.py
  test_generic_boundary_conditions.py
  test_advection.py
  test_region.py
  test_general_mesh.py
  test_combine_pts.py
  test_data_manager.py
  test_least_squares.py
  test_shallow_water.py
  test_domain.py
  test_all.py
  test_ermapper.py
  test_util.py
  test_most2nc.py
  test_smf.py
  test_interpolate_sww.py
  test_pmesh2domain.py
  test_metis.py
  test_caching.py
  test_version.py
  test_triangmodule.py
  test_alpha_shape.py
  test_numerical_tools.py
  test_polygon.py
  test_mesh.py
  test_mesh_interface.py
  test_all.py
  test_loadASCII.py
  test_all.py
  test_geo_reference.py
  test_point.py
  test_redfearn.py
  test_geospatial_data.py
WARNING: File test_metis.py excluded from testing
WARNING: File test_version.py excluded from testing
WARNING: File test_interpolate.py excluded from testing
WARNING: File test_all.py excluded from testing
buildroot I:\inundation
Traceback (most recent call last):
  File "I:\test_all.py", line 8, in ?
    execfile('test_all.py')
  File "test_all.py", line 90, in ?
    unittest.main(defaultTest='regressionTest')
  File "C:\Software\Python23\lib\unittest.py", line 720, in __init__
    self.parseArgs(argv)
  File "C:\Software\Python23\lib\unittest.py", line 747, in parseArgs
    self.createTests()
  File "C:\Software\Python23\lib\unittest.py", line 753, in createTest
s
    self.module)
  File "C:\Software\Python23\lib\unittest.py", line 519, in loadTestsF
romNames
    suites.append(self.loadTestsFromName(name, module))
  File "C:\Software\Python23\lib\unittest.py", line 504, in loadTestsF
romName
    test = obj()
  File "test_all.py", line 85, in regressionTest
    modules = map(__import__, moduleNames)
  File "I:\test_all.py", line 5, in ?
    os.chdir('inundation')
OSError: [Errno 2] No such file or directory: 'inundation'

Change History (2)

comment:1 Changed 17 years ago by ole

  • Owner changed from Ole to duncan

Since I can't reproduce the problem on any other machine, it is better that you look after it on your machine. I am happy to help, though. Meanwhile run test_all.py at the next level up.

comment:2 Changed 17 years ago by duncan

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.