Opened 14 years ago

Closed 11 years ago

#53 closed defect (fixed)

Investigate discretisation error presumably due to steep bedslopes combined with coarse triangles

Reported by: ole Owned by: someone
Priority: lowest Milestone: ANUGA maintenance
Component: Functionality and features Version: 1.0
Severity: minor Keywords: steep triangles, discretisation errors
Cc:

Description (last modified by ole)

In the vicinity of steep slopes and shallow depths we observe triangles 'sticking' out of the water. This is due to the combined constraints

  • conservation of volume
  • gradient limiters
  • h >= 0

In addition it may be that storing the output with unique vertex values averaged exacerbates this problem by affecting neighbouring triangles.

The remedies so far have been to refine areas affected.

We need a test that will reproduce the problem and then compare the two storage schemes. Alternatively, a comprehensive solution at the level of the numerical solver, but that has not yet been discovered by the team.

Change History (4)

comment:1 Changed 14 years ago by ole

  • Description modified (diff)

comment:2 Changed 14 years ago by anonymous

  • Priority changed from normal to lowest

comment:3 Changed 14 years ago by sexton

  • harbour.py seems to be a good test for this ticket due to the nature of the bathymetry.
  • harbour.py stored in ANUGA\documentation\user_manual\examples
  • see harbour.sww in that directory for example
  • harbour.py is a potential validation exercise

comment:4 Changed 11 years ago by nariman

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.