Opened 17 years ago

Closed 11 years ago

#73 closed defect (fixed)

test_advection fails on nautilus. It's to do with weave..

Reported by: duncan Owned by: Steve
Priority: low Milestone: AnuGA ready for release
Component: Compilation and installation Version: 1.0
Severity: minor Keywords:
Cc:

Description

Here's some of the error messges printed. It prints more than this though. Cyclone doesn't have this problem. On Nautilus Duncan and Jane have this problem. It works fine for Ole on Nautilus. No one has had this on cyclone or windows snadpits.

file changed
unix
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for Ada/C/ObjC but not for C++
In file included from /usr/include/python2.3/Python.h:8,
                 from /home/duncan/.python23_compiled/sc_13328
		 
	EEEEE.
======================================================================
ERROR: test_advection_example (__main__.Test_Advection)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test_advection.py", line 167, in test_advection_example
    for t in domain.evolve(yieldstep = 0.05, finaltime = 10):
  File "pyvolution/advection.py", line 366, in evolve
    skip_initial_step=skip_initial_step):
  File "pyvolution/domain.py", line 608, in evolve
    self.compute_fluxes()
  File "pyvolution/advection.py", line 122, in compute_fluxes
    self.compute_fluxes_weave()
  File "pyvolution/advection.py", line 336, in compute_fluxes_weave
    type_converters = converters.blitz, compiler='gcc');
  File "/usr/lib/python2.3/site-packages/weave/inline_tools.py", line 335, in inline
    auto_downcast = auto_downcast,
  File "/usr/lib/python2.3/site-packages/weave/inline_tools.py", line 439, in compile_function
    verbose=verbose, **kw)
  File "/usr/lib/python2.3/site-packages/weave/ext_tools.py", line 340, in compile
    verbose = verbose, **kw)
  File "/usr/lib/python2.3/site-packages/weave/build_tools.py", line 274, in build_extension
    setup(name = module_name, ext_modules = [ext],verbose=verb)
  File "/usr/lib/python2.3/site-packages/scipy_distutils/core.py", line 73, in setup
    return old_setup(**new_attr)
  File "/usr/lib/python2.3/distutils/core.py", line 166, in setup
    raise SystemExit, "error: " + str(msg)
CompileError: error: Command "g++ -pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wstrict-prototypes -fPIC -I/usr/lib/python2.3/site-packages/weave -I/usr/lib/python2.3/site-packages/weave/scxx -I/usr/lib/python2.3/site-packages/weave/blitz-20001213 -I/usr/include/python2.3 -c /home/duncan/.python23_compiled/sc_1332884f49c5046962e6d04fdb903c7d20.cpp -o /tmp/duncan/python23_intermediate/compiler_b4affb8230daad99a1fb80c00d7ddd42/home/duncan/.python23_compiled/sc_1332884f49c5046962e6d04fdb903c7d20.o" failed with exit status 1

Change History (3)

comment:1 Changed 17 years ago by ole

The problem is also observed by Ole on nautilus.

comment:2 Changed 16 years ago by anonymous

  • Priority changed from normal to low

comment:3 Changed 11 years ago by habili

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.