Opened 16 years ago

Closed 16 years ago

#94 closed defect (fixed)

sww2dem - math domain error

Reported by: sexton Owned by: ole
Priority: normal Milestone:
Component: Appearance and visualisation Version: 1.0
Severity: normal Keywords:
Cc:

Description

During production runs, we have an export_results.py script which takes a given sww file and outputs an asc grid of a desired quantity (eg elevation, depth) at a desired grid size.

A recent example from the hobart_2006 scenario returns a math domain error (in finding the angle). The same result is found for different cell sizes and different alphas (0.01, 0.1 and 1) and whether a grid or points are used to create the elevation.

The script in the hobart_2006 directory lists a series of examples which will generate the error, but importantly show an example which does work. The difference between them is whether the 50m asc grid is used as the elevation function, or whether a series of data sets are used (time_dir = 20060926_064750). However, having said that, timedir = 20060929_075009 uses points rather than grid and the error persists. BUT - having talked over lunch, the one that worked had a simple bounding polygon and the one that didn't work had a more complicated bounding polygon!

The 50m asc grid has a number of NODATA values embedded in it (but presumably dem2pts removes them?). Another example has been run where the NODATA values have been removed from the 50m asc grid, and the same result is found (time_dir = 20060929_075954).

Out of interest, I changed the bounding polygon to be defined anti-clockwise rather than clockwise, and the error persists. Again, this example is listed in the script.

Change History (1)

comment:1 Changed 16 years ago by ole

  • Resolution set to fixed
  • Status changed from new to closed

I believe this was fixed in changeset:3688

Note: See TracTickets for help on using tickets.