Opened 11 years ago

Closed 11 years ago

#318 closed defect (invalid)

error running get_timeseries.py

Reported by: kristy Owned by: rwilson
Priority: high Milestone:
Component: Functionality and features Version:
Severity: major Keywords:
Cc:

Description

When running python get_timeseries.py and get_all_swwfiles() return the sww files in the wrong order (ie not creation order), the csv data is written incorrectly. It *looks* like the last file has rewritten over the previous, however the time is just wrong???

A possible work-around is to sort the list of SWW filenames received from get_all_swwfiles(). This is currently being tested in get_timeseries.py. Maybe the sort should be in get_all_swwfiles()?

But the problem of why the output is wrong when the SWW files are processed in the wrong order still remains.

Change History (2)

comment:1 Changed 11 years ago by kristy

The source of the problem is start time in the mulitple sww files. First start time is simulation start time relative to the quake. Second and subsequent sww files are relative to the anuga simulation. Not sure if this is by desing or accident.

We have fudged the loop so that simulation time is calculated from sww file relative time plus the first sww starttime.

Note that the fudge relies on a sort() of the result from get_all_swwfiles().

comment:2 Changed 11 years ago by nariman

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.